Cosa c'è di nuovo?
HWReload

Registrati e partecipa alle attività del forum

Tastiera PS2 e Windows 10

Ryosuke

Nuovo utente
Iscritto dal:
13 Settembre 2021
Messaggi
10
Lancio un'altra discussione.
Ho una vecchia tastiera HP 5187 (anno 2004), perfettamente integra, funziona alla grande nel vecchio computer.
Se la metto nel pc nuovo (la scheda madre ha uno slot per Tastiere/mouse con ps2), le luci della tastiera si accendono, ma non funziona.
Ho provato a fare Regedit, poi HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt, impostato StartValue DWORD (32bit) da 0 a 1.
Purtroppo non fa funzionato.

Qualcuno hai suggerimenti per farla funzionare?
 

Federico83

Moderatore
Staff
Iscritto dal:
23 Dicembre 2017
Messaggi
644
Lancio un'altra discussione.
Ho una vecchia tastiera HP 5187 (anno 2004), perfettamente integra, funziona alla grande nel vecchio computer.
Se la metto nel pc nuovo (la scheda madre ha uno slot per Tastiere/mouse con ps2), le luci della tastiera si accendono, ma non funziona.
Ho provato a fare Regedit, poi HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt, impostato StartValue DWORD (32bit) da 0 a 1.
Purtroppo non fa funzionato.

Qualcuno hai suggerimenti per farla funzionare?
Ciao la tastiera ps2 deve essere collegata a pc spento essendo analogica, io ne ho una collegata al mio pc di lavoro e funziona senza problemi
 

Ryosuke

Nuovo utente
Iscritto dal:
13 Settembre 2021
Messaggi
10
Sì, sì naturalmente inserisco quando il pc è spento. quando accendo il pc, le luci della tastiera si accendono normalmente, ma non funziona.
Al contrario il mouse con ps2 va perfettamente
 

Federico83

Moderatore
Staff
Iscritto dal:
23 Dicembre 2017
Messaggi
644
Sì, sì naturalmente inserisco quando il pc è spento. quando accendo il pc, le luci della tastiera si accendono normalmente, ma non funziona.
Al contrario il mouse con ps2 va perfettamente
non è che c'è da settare qualcosa nel bios?
 

Ryosuke

Nuovo utente
Iscritto dal:
13 Settembre 2021
Messaggi
10
Non ne ho idea. Per esempio il mouse va perfettamente. A dir la verità sono anche poco pratico col bios. Secondo te cosa potrei fare?
 

Federico83

Moderatore
Staff
Iscritto dal:
23 Dicembre 2017
Messaggi
644
Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt the Start key should be changed from 3 to 1.

Value StartType Description
0 Boot Specifies a driver that is loaded (but not started)
by the boot loader. If no errors occur, the driver is
started during kernel initialization prior to any
non-boot drivers being loaded.

1 System Specifies a driver that loads and starts during kernel
initialization after drivers with a Start value of 0
have been started.

2 Auto Load Specifies a driver or service that is initialized at
system startup by Session Manager (Smss.exe) or the
Services Controller (Services.exe).

3 Load on Demand Specifies a driver or service that the Service Control
Manager (SCM) will start only on demand. These drivers have
to be started manually by calling a Win32 SCM application
programming interface (API), such as the Services snap-in.

4 Disable Specifies a disabled (not started) driver or service.

5 Delayed Start Specifies that less-critical services will start shortly after
startup to allow the operating system to be responsive to
the user sooner. This start type was first introduced
in Windows Vista.


prova a variare questi valori magari riesci a farla andare
 

Ryosuke

Nuovo utente
Iscritto dal:
13 Settembre 2021
Messaggi
10
Ho provato tutte le combinazioni, ma non va.
Ho provato a risalire al driver con software generici come driver toolkit oppure outbyte driver, ma quest'ultimi sono a pagamento e comunque non una garanzia che funzioni davvero.
Cosa mi suggerisci di fare?
 

Federico83

Moderatore
Staff
Iscritto dal:
23 Dicembre 2017
Messaggi
644
Ho provato tutte le combinazioni, ma non va.
Ho provato a risalire al driver con software generici come driver toolkit oppure outbyte driver, ma quest'ultimi sono a pagamento e comunque non una garanzia che funzioni davvero.
Cosa mi suggerisci di fare?
in rete sembra che chi abbia il tuo stesso problema non ha risolto quindi magari prova con un aggiornamento del bios se disponibile
 

Ryosuke

Nuovo utente
Iscritto dal:
13 Settembre 2021
Messaggi
10
Ci sono riuscito!!!!
Ho seguito questa procedura: ho pigiato ctrl+x, gestione dispositivi, Tastiere, PS2, aggiorna driver.
Praticamente il ps2 recepiva il mouse. Per ogni dispositivo con ps2 bisogna fare questo aggiornamento.
Affinché recepisse di nuovo un mouse ps2, sono andato sul bios e poi sono uscito.
Ho voluto provare tutte queste procedure perché tastiera e mouse ps2 sono le mie periferiche di riserva, che a dispetto gli anni funzionano ancora benone.

Per usarli contemporaneamente, dovrei usare un adattatore ps2-usb. Che tu sappia questo tipo di connettori sono affidabili?
 
Top